ProFormA-Editor

Editor zum Erstellen von ProFormA-Programmieraufgaben

Das Aufgabenformat hat sich im Laufe der Zeit geändert. Format 2.0 ist nicht kompatibel mit 1.0.1. Neue Aufgaben sollten nur noch im Format 2.0 erstellt werden, da das alte Format von neuen Tools vermutlich nicht mehr unterstützt wird.

Der Editor läuft nicht in jedem Browser. Erfolgreich getestet sind Chrome und Firefox (ab 3.0.0 vermutlich auch Edge).

Format 2.0 (proforma.xsd)

Für Aufgaben, die in LON-CAPA laufen sollen, bitte dieses Format nicht nutzen! Die Aufgaben laufen nicht in LON-CAPA.

Der Editor liest neben Format 2.0 auch noch das Format 1.0.1, schreibt aber immer Format 2.0. Er kann somit auch zum Konvertieren alter Aufgaben genutzt werden.

Format 1.0.1 (task.xsd)

Alte Releases